Why are some GDI functions named ExtXxx instead of XxxEx?
By convention, an enhanced version of a function
Xxx is called
XxxEx, but there are many GDI functions that don’t follow this conventions, most notably
ExtTextOut, which should have been named
TextOutEx under the
XxxEx convention. Why don’t the GDI functions follow that convention?
Because they were named before the
XxxEx convention was established.
Nothing nefarious, just an artifact of history.